The following metadata has been embedded in the body. Website Malware Removal Service – [20161205] - PHPMailer Security Advisory

[20161205] – PHPMailer Security Advisory

Posted by MalRemServ on 27 12 2016. 0 Comments

  • Project: Joomla!
  • Severity: High
  • Versions: 1.6.0 through 3.6.5
  • Exploit type: Remote Code Execution in PHPMailer library
  • CVE Number: CVE-2016-10033

Description

All versions of the PHPMailer library distributed with Joomla are vulnerable to a remote code execution vulnerability. This is patched in PHPMailer 5.2.18 which will be included with Joomla! 3.7. After analysis, the JSST has determined that through correct use of the JMail class, there are additional validations in place which make executing this vulnerability impractical within the Joomla environment. As well, the vulnerability requires being able to pass user input to a message’s “from” address; all places in the core Joomla API which send mail use the sender address set in the global configuration and does not allow for user input to be set elsewhere. However, extensions which bundle a separate version of PHPMailer or do not use the Joomla API to send email may be vulnerable to this issue.

Generally, the Joomla project does not issue advisories regarding third party libraries, however given the severity of this issue we felt it important to advise our users that we are aware of this issue and we have determined that the additional validations in our API prevent triggering this vulnerability.

Affected Installs

Joomla! CMS versions 1.6.0 through 3.6.5

Solution

No action required for Joomla users, the updated library will be included in the next scheduled release and additional mechanisms exist in Joomla core to prevent triggering the vulnerability. Users of the PHPMailer library separate from Joomla are advised to upgrade to 5.2.18 or newer ASAP.

Additional Resources

Contact

The JSST at the Joomla! Security Centre.

Reported By: Dawid Golunski



This information provided by Security Announcements. For more information or details on this exploit or vulnerability, please visit Link.

If you have this installed, we highly recommend you update to the latest version immediately, or if you are no longer using it, remove it from your site. If your site has been compromised due to this vulnerability, we can help.

If you aren’t technical and you need immediate assistance, we can reduce the impact and prevent further damage quickly – Now is your chance, we can have the typical site cleaned and secured in just a few hours. Check out our Pricing page for details on our professional, reliable malware removal services.